What’s Vulnerable › Vulnerabilities
CVE-2024-2344: Avada <= 7.11.6 - Authenticated (Admin+) SQL Injection via entry
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-09 · updated 2026-06-17
- Weakness: CWE-89
Description
The Avada theme for WordPress is vulnerable to SQL Injection via the 'entry' parameter in all versions up to, and including, 7.11.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticted attackers, with editor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- ThemeFusion Avada | Website Builder For WordPress & WooCommerce: before 7.11.7 — fixed in 7.11.7
How to fix
Upgrade to a fixed version: ThemeFusion Avada | Website Builder For WordPress & WooCommerce 7.11.7. Check the vendor advisory for mitigations.
References
- https://avada.com/documentation/avada-changelog/
- https://gist.github.com/Xib3rR4dAr/05a32f63d75082ab05de27e313e70fa3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ccf0d2ca-2891-45d1-8ea2-90dd435b359f?source=cve
- https://avada.com/documentation/avada-changelog/
- https://gist.github.com/Xib3rR4dAr/05a32f63d75082ab05de27e313e70fa3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ccf0d2ca-2891-45d1-8ea2-90dd435b359f?source=cve
Get alerted when CVE-2024-2344 or the next vulnerability affects your stack