What’s Vulnerable › Vulnerabilities
CVE-2024-23443
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-06-17
- Weakness: CWE-400
Description
A high-privileged user, allowed to create custom osquery packs 17 could affect the availability of Kibana by uploading a maliciously crafted osquery pack.
Affected products
- Kibana: from 7.0.0 before 7.17.22; from 8.0.0 before 8.14.0 — fixed in 7.17.22, 8.14.0
How to fix
Upgrade to a fixed version: Kibana 7.17.22, 8.14.0. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/kibana-8-14-0-7-17-22-security-update-esa-2024-11/361460
- https://discuss.elastic.co/t/kibana-8-14-0-7-17-22-security-update-esa-2024-11/361460
Get alerted when CVE-2024-23443 or the next vulnerability affects your stack