What’s Vulnerable › Vulnerabilities
CVE-2024-23450: Elasticsearch Uncontrolled Resource Consumption vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-27 · updated 2026-06-17
- Weakness: CWE-400
Description
A flaw was discovered in Elasticsearch, where processing a document in a deeply nested pipeline on an ingest node could cause the Elasticsearch node to crash.
Affected products
- Elasticsearch: from 7.0.0 before 7.17.19; from 8.0.0 before 8.13.0 — fixed in 7.17.19, 8.13.0
How to fix
Upgrade to a fixed version: Elasticsearch 7.17.19, 8.13.0. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elasticsearch-8-13-0-7-17-19-security-update-esa-2024-06/356314
- https://security.netapp.com/advisory/ntap-20240517-0010/
- https://www.elastic.co/community/security
- https://discuss.elastic.co/t/elasticsearch-8-13-0-7-17-19-security-update-esa-2024-06/356314
- https://security.netapp.com/advisory/ntap-20240517-0010/
- https://www.elastic.co/community/security
Get alerted when CVE-2024-23450 or the next vulnerability affects your stack