What’s Vulnerable › Vulnerabilities
CVE-2024-23452: Apache bRPC: HTTP request smuggling vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-08 · updated 2026-06-17
- Weakness: CWE-444
Description
Request smuggling vulnerability in HTTP server in Apache bRPC 0.9.5~1.7.0 on all platforms allows attacker to smuggle request. Vulnerability Cause Description: The http_parser does not comply with the RFC-7230 HTTP 1.1 specification. Attack scenario: If a message is received with both a Transfer-Encoding and a Content-Length header field, such a message might indicate an attempt to perform request smuggling or response splitting. One particular attack scenario is that a bRPC made http server on the backend receiving requests in one persistent connection from frontend server that uses TE to parse request with the logic that 'chunk' is contained in the TE field. in that case an attacker can smuggle a request into the connection to the backend server. Solution: You can choose one solution from below: 1. Upgrade bRPC to version 1.8.0, which fixes this issue. Download link: https://github.com/apache/brpc/releases/tag/1.8.0 2. Apply this patch: https://github.com/apache/brpc/pull/2518
Affected products
- Apache Software Foundation Apache bRPC: from 0.9.5 before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache bRPC 1.8.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/08/1
- https://github.com/apache/brpc/pull/2518
- https://github.com/apache/brpc/releases/tag/1.8.0
- https://lists.apache.org/thread/kkvdpwyr2s2yt9qvvxfdzon012898vxd
- http://www.openwall.com/lists/oss-security/2024/02/08/1
- https://github.com/apache/brpc/pull/2518
- https://github.com/apache/brpc/releases/tag/1.8.0
- https://lists.apache.org/thread/kkvdpwyr2s2yt9qvvxfdzon012898vxd
Get alerted when CVE-2024-23452 or the next vulnerability affects your stack