What’s Vulnerable › Vulnerabilities
CVE-2024-23483: Local Privilege Escalation via lack of input validation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-06 · updated 2026-06-17
- Weakness: CWE-20
Description
An Improper Input Validation vulnerability in Zscaler Client Connector on MacOS allows OS Command Injection. This issue affects Zscaler Client Connector on MacOS <4.2.
Affected products
- Zscaler Client Connector: before 4.2 — fixed in 4.2
How to fix
Upgrade to a fixed version: Zscaler Client Connector 4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-23483 or the next vulnerability affects your stack