What’s Vulnerable › Vulnerabilities
CVE-2024-2352: 1Panel swap baseApi.UpdateDeviceSwap command injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-10 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability, which was classified as critical, has been found in 1Panel up to 1.10.1-lts. Affected by this issue is the function baseApi.UpdateDeviceSwap of the file /api/v1/toolbox/device/update/swap. The manipulation of the argument Path with the input 123123123\nopen -a Calculator leads to command injection. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-256304.
Affected products
- 1Panel-dev 1Panel: before 1.10.2-lts — fixed in 1.10.2-lts
How to fix
Upgrade to a fixed version: 1Panel-dev 1Panel 1.10.2-lts. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/1Panel/pull/4131
- https://github.com/1Panel-dev/1Panel/pull/4131#issue-2176105990
- https://github.com/1Panel-dev/1Panel/pull/4131/commits/0edd7a9f6f5100aab98a0ea6e5deedff7700396c
- https://vuldb.com/?ctiid.256304
- https://vuldb.com/?id.256304
- https://github.com/1Panel-dev/1Panel/pull/4131
- https://github.com/1Panel-dev/1Panel/pull/4131#issue-2176105990
- https://github.com/1Panel-dev/1Panel/pull/4131/commits/0edd7a9f6f5100aab98a0ea6e5deedff7700396c
- https://vuldb.com/?ctiid.256304
- https://vuldb.com/?id.256304
Get alerted when CVE-2024-2352 or the next vulnerability affects your stack