What’s Vulnerable › Vulnerabilities
CVE-2024-23527
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-25 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read vulnerability in WLAvalancheService component of Ivanti Avalanche before 6.4.3, in certain conditions can allow an unauthenticated remote attacker to read sensitive information in memory.
Affected products
- Ivanti Avalanche: before 6.4.3.528 — fixed in 6.4.3.528
How to fix
Upgrade to a fixed version: Ivanti Avalanche 6.4.3.528. Check the vendor advisory for mitigations.
References
- https://www.ivanti.com/blog/security-update-for-ivanti-avalanche
- https://www.ivanti.com/blog/security-update-for-ivanti-avalanche
Get alerted when CVE-2024-23527 or the next vulnerability affects your stack