What’s Vulnerable › Vulnerabilities
CVE-2024-23531
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-19 · updated 2026-06-17
- Weakness: CWE-190
Description
An Integer Overflow vulnerability in WLInfoRailService component of Ivanti Avalanche before 6.4.3 allows an unauthenticated remote attacker to perform denial of service attacks. In certain rare conditions this could also lead to reading content from memory.
Affected products
- Ivanti Avalanche: before 6.4.3.528 — fixed in 6.4.3.528
How to fix
Upgrade to a fixed version: Ivanti Avalanche 6.4.3.528. Check the vendor advisory for mitigations.
References
- https://forums.ivanti.com/s/article/Avalanche-6-4-3-Security-Hardening-and-CVEs-addressed?language=en_US
- https://forums.ivanti.com/s/article/Avalanche-6-4-3-Security-Hardening-and-CVEs-addressed?language=en_US
Get alerted when CVE-2024-23531 or the next vulnerability affects your stack