What’s Vulnerable › Vulnerabilities
CVE-2024-23537: Apache Fineract: Under certain circumstances, this vulnerability allowed users, without specific permissions, to escalate their privileges to any role.
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-269
Description
Improper Privilege Management vulnerability in Apache Fineract.This issue affects Apache Fineract: <1.8.5. Users are recommended to upgrade to version 1.9.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Fineract: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fineract 1.9.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/29/1
- https://cwiki.apache.org/confluence/display/FINERACT/Apache+Fineract+Security+Report
- https://lists.apache.org/thread/fq1ns4nprw2vqpkwwj9sw45jkwxmt9f1
- http://www.openwall.com/lists/oss-security/2024/03/29/1
- https://cwiki.apache.org/confluence/display/FINERACT/Apache+Fineract+Security+Report
- https://lists.apache.org/thread/fq1ns4nprw2vqpkwwj9sw45jkwxmt9f1
Get alerted when CVE-2024-23537 or the next vulnerability affects your stack