What’s Vulnerable › Vulnerabilities
CVE-2024-23539: Apache Fineract: Under certain system configurations, the sqlSearch parameter for specific endpoints was vulnerable to SQL injection attacks, potentially allowing attackers to manipulate database queries.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Fineract.This issue affects Apache Fineract: <1.8.5. Users are recommended to upgrade to version 1.8.5 or 1.9.0, which fix the issue.
Affected products
- Apache Software Foundation Apache Fineract: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Fineract 1.9.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/03/29/3
- https://cwiki.apache.org/confluence/display/FINERACT/Apache+Fineract+Security+Report
- https://lists.apache.org/thread/g8sv1gnjv716lx2h89jbvjdgtrrjmy7h
- http://www.openwall.com/lists/oss-security/2024/03/29/3
- https://cwiki.apache.org/confluence/display/FINERACT/Apache+Fineract+Security+Report
- https://lists.apache.org/thread/g8sv1gnjv716lx2h89jbvjdgtrrjmy7h
Get alerted when CVE-2024-23539 or the next vulnerability affects your stack