What’s Vulnerable › Vulnerabilities
CVE-2024-2358: Path Traversal leading to Remote Code Execution in parisneo/lollms-webui
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-29
Description
A path traversal vulnerability in the '/apply_settings' endpoint of parisneo/lollms-webui allows attackers to execute arbitrary code. The vulnerability arises due to insufficient sanitization of user-supplied input in the configuration settings, specifically within the 'extensions' parameter. Attackers can exploit this by crafting a payload that includes relative path traversal sequences ('../../../'), enabling them to navigate to arbitrary directories. This flaw subsequently allows the server to load and execute a malicious '__init__.py' file, leading to remote code execution. The issue affects the latest version of parisneo/lollms-webui.
Affected products
- ParisNeo lollms-webui: before 9.5 — fixed in 9.5
How to fix
Upgrade to a fixed version: ParisNeo lollms-webui 9.5. Check the vendor advisory for mitigations.
References
- https://huntr.com/bounties/b2771df3-be50-45bd-93c4-0974ce38bc22
- https://huntr.com/bounties/b2771df3-be50-45bd-93c4-0974ce38bc22
Get alerted when CVE-2024-2358 or the next vulnerability affects your stack