What’s Vulnerable › Vulnerabilities
CVE-2024-23590: Apache Kylin: Session fixation in web interface
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-04 · updated 2026-06-17
- Weakness: CWE-384
Description
Session Fixation vulnerability in Apache Kylin. This issue affects Apache Kylin: from 2.0.0 through 4.x. Users are recommended to upgrade to version 5.0.0 or above, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kylin: from 2.0.0 before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 5.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/7161154h0k6zygr9917qq0g95p39szml
- http://www.openwall.com/lists/oss-security/2024/11/03/1
Get alerted when CVE-2024-23590 or the next vulnerability affects your stack