What’s Vulnerable › Vulnerabilities
CVE-2024-23640: GeoServer Stored Cross-Site Scripting (XSS) vulnerability in Style Publisher
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.3 and 2.24.0 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources or in a specially crafted datastore file that will execute in the context of another user's browser when viewed in the Style Publisher. Access to the Style Publisher is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.3 and 2.24.0 contain a fix for this issue.
Affected products
- geoserver: before 2.23.3 — fixed in 2.23.3
How to fix
Upgrade to a fixed version: geoserver 2.23.3. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/pull/7162
- https://github.com/geoserver/geoserver/pull/7181
- https://github.com/geoserver/geoserver/security/advisories/GHSA-9rfr-pf2x-g4xf
- https://osgeo-org.atlassian.net/browse/GEOS-11149
- https://osgeo-org.atlassian.net/browse/GEOS-11155
- https://github.com/geoserver/geoserver/pull/7162
- https://github.com/geoserver/geoserver/pull/7181
- https://github.com/geoserver/geoserver/security/advisories/GHSA-9rfr-pf2x-g4xf
- https://osgeo-org.atlassian.net/browse/GEOS-11149
- https://osgeo-org.atlassian.net/browse/GEOS-11155
Get alerted when CVE-2024-23640 or the next vulnerability affects your stack