What’s Vulnerable › Vulnerabilities
CVE-2024-23643: GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.2 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another administrator’s browser when viewed in the GWC Seed Form. Access to the GWC Seed Form is limited to full administrators by default and granting non-administrators access to this endpoint is not recommended. Versions 2.23.2 and 2.24.1 contain a fix for this issue.
Affected products
- geoserver: before 2.23.2; 2.24.0 — fixed in 2.23.2
How to fix
Upgrade to a fixed version: geoserver 2.23.2. Check the vendor advisory for mitigations.
References
- https://github.com/GeoWebCache/geowebcache/commit/9d010e09c784690ada8af43f594461a2553a62f0
- https://github.com/GeoWebCache/geowebcache/issues/1172
- https://github.com/GeoWebCache/geowebcache/pull/1174
- https://github.com/geoserver/geoserver/security/advisories/GHSA-56r3-f536-5gf7
- https://github.com/GeoWebCache/geowebcache/commit/9d010e09c784690ada8af43f594461a2553a62f0
- https://github.com/GeoWebCache/geowebcache/issues/1172
- https://github.com/GeoWebCache/geowebcache/pull/1174
- https://github.com/geoserver/geoserver/security/advisories/GHSA-56r3-f536-5gf7
Get alerted when CVE-2024-23643 or the next vulnerability affects your stack