What’s Vulnerable › Vulnerabilities
CVE-2024-23646: Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-24 · updated 2026-06-17
- Weakness: CWE-89
Description
Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. The application allows users to create zip files from available files on the site. In the 1.x branch prior to version 1.3.2, parameter `selectedIds` is susceptible to SQL Injection. Any backend user with very basic permissions can execute arbitrary SQL statements and thus alter any data or escalate their privileges to at least admin level. Version 1.3.2 contains a fix for this issue.
Affected products
- pimcore admin-ui-classic-bundle: from 1.0.0 before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: pimcore admin-ui-classic-bundle 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/admin-ui-classic-bundle/blob/1.x/src/Controller/Admin/Asset/AssetController.php#L2006
- https://github.com/pimcore/admin-ui-classic-bundle/blob/1.x/src/Controller/Admin/Asset/AssetController.php#L2087
- https://github.com/pimcore/admin-ui-classic-bundle/commit/363afef29496cc40a8b863c2ca2338979fcf50a8
- https://github.com/pimcore/admin-ui-classic-bundle/releases/tag/v1.3.2
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-cwx6-4wmf-c6xv
- https://github.com/pimcore/admin-ui-classic-bundle/blob/1.x/src/Controller/Admin/Asset/AssetController.php#L2006
- https://github.com/pimcore/admin-ui-classic-bundle/blob/1.x/src/Controller/Admin/Asset/AssetController.php#L2087
- https://github.com/pimcore/admin-ui-classic-bundle/commit/363afef29496cc40a8b863c2ca2338979fcf50a8
- https://github.com/pimcore/admin-ui-classic-bundle/releases/tag/v1.3.2
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-cwx6-4wmf-c6xv
Get alerted when CVE-2024-23646 or the next vulnerability affects your stack