What’s Vulnerable › Vulnerabilities
CVE-2024-23647: PKCE downgrade attack in Authentik
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-30 · updated 2026-06-17
- Weakness: CWE-287
Description
Authentik is an open-source Identity Provider. There is a bug in our implementation of PKCE that allows an attacker to circumvent the protection that PKCE offers. PKCE adds the code_challenge parameter to the authorization request and adds the code_verifier parameter to the token request. Prior to 2023.8.7 and 2023.10.7, a downgrade scenario is possible: if the attacker removes the code_challenge parameter from the authorization request, authentik will not do the PKCE check. Because of this bug, an attacker can circumvent the protection PKCE offers, such as CSRF attacks and code injection attacks. Versions 2023.8.7 and 2023.10.7 fix the issue.
Affected products
- goauthentik authentik: before 2023.8.7; from 2023.10.0 before 2023.10.7 — fixed in 2023.10.7, 2023.8.7
How to fix
Upgrade to a fixed version: goauthentik authentik 2023.10.7, 2023.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/goauthentik/authentik/commit/38e04ae12720e5d81b4f7ac77997eb8d1275d31a
- https://github.com/goauthentik/authentik/security/advisories/GHSA-mrx3-gxjx-hjqj
- https://github.com/goauthentik/authentik/commit/38e04ae12720e5d81b4f7ac77997eb8d1275d31a
- https://github.com/goauthentik/authentik/security/advisories/GHSA-mrx3-gxjx-hjqj
Get alerted when CVE-2024-23647 or the next vulnerability affects your stack