What’s Vulnerable › Vulnerabilities
CVE-2024-23653: BuildKit interactive containers API does not validate entitlements check
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-31 · updated 2026-06-17
- Weakness: CWE-863
Description
BuildKit is a toolkit for converting source code to build artifacts in an efficient, expressive and repeatable manner. In addition to running containers as build steps, BuildKit also provides APIs for running interactive containers based on built images. It was possible to use these APIs to ask BuildKit to run a container with elevated privileges. Normally, running such containers is only allowed if special `security.insecure` entitlement is enabled both by buildkitd configuration and allowed by the user initializing the build request. The issue has been fixed in v0.12.5 . Avoid using BuildKit frontends from untrusted sources.
Affected products
- moby BuildKit: before 0.12.5 — fixed in 0.12.5
How to fix
Upgrade to a fixed version: moby BuildKit 0.12.5. Check the vendor advisory for mitigations.
References
- https://github.com/moby/buildkit/pull/4602
- https://github.com/moby/buildkit/releases/tag/v0.12.5
- https://github.com/moby/buildkit/security/advisories/GHSA-wr6v-9f75-vh2g
- https://github.com/moby/buildkit/pull/4602
- https://github.com/moby/buildkit/releases/tag/v0.12.5
- https://github.com/moby/buildkit/security/advisories/GHSA-wr6v-9f75-vh2g
Get alerted when CVE-2024-23653 or the next vulnerability affects your stack