What’s Vulnerable › Vulnerabilities

CVE-2024-23672: Apache Tomcat: WebSocket DoS with incomplete closing handshake

Description

Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. It was possible for WebSocket clients to keep WebSocket connections open leading to increased resource consumption.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.19, 8.5.99, 9.0.86. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-23672 or the next vulnerability affects your stack