What’s Vulnerable › Vulnerabilities
CVE-2024-23673: Apache Sling Servlets Resolver: Malicious code execution via path traversal
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-06 · updated 2026-06-17
- Weakness: CWE-22
Description
Malicious code execution via path traversal in Apache Software Foundation Apache Sling Servlets Resolver.This issue affects all version of Apache Sling Servlets Resolver before 2.11.0. However, whether a system is vulnerable to this attack depends on the exact configuration of the system. If the system is vulnerable, a user with write access to the repository might be able to trick the Sling Servlet Resolver to load a previously uploaded script. Users are recommended to upgrade to version 2.11.0, which fixes this issue. It is recommended to upgrade, regardless of whether your system configuration currently allows this attack or not.
Affected products
- Apache Software Foundation Apache Sling Servlets Resolver: before 2.11.0 — fixed in 2.11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Sling Servlets Resolver 2.11.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/06/1
- https://lists.apache.org/thread/5zzx8ztwc6tmbwlw80m2pbrp3913l2kl
- http://www.openwall.com/lists/oss-security/2024/02/06/1
- https://lists.apache.org/thread/5zzx8ztwc6tmbwlw80m2pbrp3913l2kl
Get alerted when CVE-2024-23673 or the next vulnerability affects your stack