What’s Vulnerable › Vulnerabilities
CVE-2024-2368: Mollie Forms <= 2.6.13 - Cross-Site Request Forgery to Arbitrary Post Duplication
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-05 · updated 2026-06-17
- Weakness: CWE-352
Description
The Mollie Forms plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.13. This is due to missing or incorrect nonce validation on the duplicateForm() function. This makes it possible for unauthenticated attackers to duplicate forms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- ndijkstra Mollie Forms: before 2.6.14 — fixed in 2.6.14
How to fix
Upgrade to a fixed version: ndijkstra Mollie Forms 2.6.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3097426/mollie-forms
- https://www.wordfence.com/threat-intel/vulnerabilities/id/51ff10f2-4a5b-42ab-9ee2-95b036ac1c9a?source=cve
- https://plugins.trac.wordpress.org/changeset/3097426/mollie-forms
- https://www.wordfence.com/threat-intel/vulnerabilities/id/51ff10f2-4a5b-42ab-9ee2-95b036ac1c9a?source=cve
Get alerted when CVE-2024-2368 or the next vulnerability affects your stack