What’s Vulnerable › Vulnerabilities

CVE-2024-23680: AWS Encryption SDK for Java Improper Verification of Cryptographic Signature

Description

AWS Encryption SDK for Java versions 2.0.0 to 2.2.0 and less than 1.9.0 incorrectly validates some invalid ECDSA signatures.

Affected products

How to fix

Upgrade to a fixed version: Amazon AWS SDK 1.9.0, 2.2.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-23680 or the next vulnerability affects your stack