What’s Vulnerable › Vulnerabilities
CVE-2024-23684: upokecenter CBOR Denial of Service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-19 · updated 2026-07-14
- Weakness: CWE-407
Description
Inefficient algorithmic complexity in DecodeFromBytes function in com.upokecenter.cbor Java implementation of Concise Binary Object Representation (CBOR) versions 4.0.0 to 4.5.1 allows an attacker to cause a denial of service by passing a maliciously crafted input. Depending on an application's use of this library, this may be a remote attacker.
Affected products
- Peteroupc Cbor: from 4.0.0 before 4.5.1 — fixed in 4.5.1
How to fix
Upgrade to a fixed version: Peteroupc Cbor 4.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-fj2w-wfgv-mwq6
- https://github.com/peteroupc/CBOR-Java/security/advisories/GHSA-fj2w-wfgv-mwq6
- https://vulncheck.com/advisories/vc-advisory-GHSA-fj2w-wfgv-mwq6
- https://github.com/advisories/GHSA-fj2w-wfgv-mwq6
- https://github.com/peteroupc/CBOR-Java/security/advisories/GHSA-fj2w-wfgv-mwq6
- https://vulncheck.com/advisories/vc-advisory-GHSA-fj2w-wfgv-mwq6
Get alerted when CVE-2024-23684 or the next vulnerability affects your stack