What’s Vulnerable › Vulnerabilities
CVE-2024-2369: Page Builder Gutenberg Blocks < 3.1.7 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder Gutenberg Blocks WordPress plugin before 3.1.7 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- godaddy Page Builder Gutenberg Blocks – CoBlocks: before 3.1.7 — fixed in 3.1.7
How to fix
Upgrade to a fixed version: godaddy Page Builder Gutenberg Blocks – CoBlocks 3.1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/252dfc35-4c8c-4304-aa09-73dfe986b10d/
- https://wpscan.com/vulnerability/252dfc35-4c8c-4304-aa09-73dfe986b10d/
Get alerted when CVE-2024-2369 or the next vulnerability affects your stack