What’s Vulnerable › Vulnerabilities
CVE-2024-23730
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-21 · updated 2026-06-17
Description
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
Affected products
- Llamahub: before 0.0.67 — fixed in 0.0.67
How to fix
Upgrade to a fixed version: Llamahub 0.0.67. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama-hub/blob/v0.0.67/CHANGELOG.md
- https://github.com/run-llama/llama-hub/pull/841/commits/9dc9c21a5c6d0226d1d2101c3121d4f085743d52
- https://github.com/run-llama/llama-hub/releases/tag/v0.0.67
- https://github.com/run-llama/llama-hub/blob/v0.0.67/CHANGELOG.md
- https://github.com/run-llama/llama-hub/pull/841/commits/9dc9c21a5c6d0226d1d2101c3121d4f085743d52
- https://github.com/run-llama/llama-hub/releases/tag/v0.0.67
Get alerted when CVE-2024-23730 or the next vulnerability affects your stack