What’s Vulnerable › Vulnerabilities
CVE-2024-23731
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-21 · updated 2026-06-17
- Weakness: CWE-88
Description
The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument.
Affected products
- Embedchain: before 0.1.57 — fixed in 0.1.57
How to fix
Upgrade to a fixed version: Embedchain 0.1.57. Check the vendor advisory for mitigations.
References
- https://github.com/embedchain/embedchain/compare/0.1.56...0.1.57
- https://github.com/embedchain/embedchain/pull/1122
- https://github.com/embedchain/embedchain/compare/0.1.56...0.1.57
- https://github.com/embedchain/embedchain/pull/1122
Get alerted when CVE-2024-23731 or the next vulnerability affects your stack