What’s Vulnerable › Vulnerabilities
CVE-2024-23732
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-21 · updated 2026-06-17
- Weakness: CWE-1333
Description
The JSON loader in Embedchain before 0.1.57 allows a ReDoS (regular expression denial of service) via a long string to json.py.
Affected products
- Embedchain: before 0.1.57 — fixed in 0.1.57
How to fix
Upgrade to a fixed version: Embedchain 0.1.57. Check the vendor advisory for mitigations.
References
- https://github.com/embedchain/embedchain/compare/0.1.56...0.1.57
- https://github.com/embedchain/embedchain/pull/1122
- https://github.com/embedchain/embedchain/compare/0.1.56...0.1.57
- https://github.com/embedchain/embedchain/pull/1122
Get alerted when CVE-2024-23732 or the next vulnerability affects your stack