What’s Vulnerable › Vulnerabilities
CVE-2024-23738
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-28 · updated 2026-06-17
Description
An issue in Postman version 10.22 and before on macOS allows a remote attacker to execute arbitrary code via the RunAsNode and enableNodeClilnspectArguments settings. NOTE: the vendor states "we dispute the report's accuracy ... the configuration does not enable remote code execution.."
Affected products
- Postman: before 10.22 — fixed in 10.22
How to fix
Upgrade to a fixed version: Postman 10.22. Check the vendor advisory for mitigations.
References
- https://github.com/V3x0r/CVE-2024-23738
- https://www.electronjs.org/blog/statement-run-as-node-cves
- https://github.com/V3x0r/CVE-2024-23738
- https://www.electronjs.org/blog/statement-run-as-node-cves
Get alerted when CVE-2024-23738 or the next vulnerability affects your stack