What’s Vulnerable › Vulnerabilities
CVE-2024-2374: XML External Entity Injection in Multiple WSO2 Products Allows Arbitrary file read and Denial of Service
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-06-17
- Weakness: CWE-611
Description
The XML parsers within multiple WSO2 products accept user-supplied XML data without properly configuring to prevent the resolution of external entities. This omission allows malicious actors to craft XML payloads that exploit the parser's behavior, leading to the inclusion of external resources. By leveraging this vulnerability, an attacker can read confidential files from the file system and access limited HTTP resources reachable by the product. Additionally, the vulnerability can be exploited to perform denial of service attacks by exhausting server resources through recursive entity expansion or fetching large external resources.
Affected products
- WSO2 API Manager: from 3.1.0 before 3.1.0.278; from 3.2.0 before 3.2.0.368; from 4.0.0 before 4.0.0.280; from 4.1.0 before 4.1.0.206; from 4.2.0 before 4.2.0.144; from 4.3.0 before 4.3.0.57 — fixed in 3.1.0.278, 3.2.0.368, 4.0.0.280, 4.1.0.206, 4.2.0.144, 4.3.0.57
- WSO2 Identity Server: from 5.10.0 before 5.10.0.300; from 5.11.0 before 5.11.0.329; from 6.0.0 before 6.0.0.179; from 6.1.0 before 6.1.0.136 — fixed in 5.10.0.300, 5.11.0.329, 6.0.0.179, 6.1.0.136
- WSO2 Identity Server As Key Manager: from 5.10.0 before 5.10.0.296 — fixed in 5.10.0.296
- WSO2 Open Banking Am: from 2.0.0 before 2.0.0.328 — fixed in 2.0.0.328
- WSO2 Open Banking Iam: from 2.0.0 before 2.0.0.348 — fixed in 2.0.0.348
How to fix
Upgrade to a fixed version: WSO2 API Manager 3.1.0.278, 3.2.0.368, 4.0.0.280, 4.1.0.206; WSO2 Identity Server 5.10.0.300, 5.11.0.329, 6.0.0.179, 6.1.0.136; WSO2 Identity Server As Key Manager 5.10.0.296; WSO2 Open Banking Am 2.0.0.328; WSO2 Open Banking Iam 2.0.0.348. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-2374 or the next vulnerability affects your stack