What’s Vulnerable › Vulnerabilities
CVE-2024-23771
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-22 · updated 2026-06-17
- Weakness: CWE-203
Description
darkhttpd before 1.15 uses strcmp (which is not constant time) to verify authentication, which makes it easier for remote attackers to bypass authentication via a timing side channel.
Affected products
- darkhttpd: before 1.15 — fixed in 1.15
How to fix
Upgrade to a fixed version: darkhttpd 1.15. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/01/25/1
- https://github.com/emikulic/darkhttpd/commit/f477619d49f3c4de9ad59bd194265a48ddc03f04
- https://github.com/emikulic/darkhttpd/compare/v1.14...v1.15
- http://www.openwall.com/lists/oss-security/2024/01/25/1
- https://github.com/emikulic/darkhttpd/commit/f477619d49f3c4de9ad59bd194265a48ddc03f04
- https://github.com/emikulic/darkhttpd/compare/v1.14...v1.15
Get alerted when CVE-2024-23771 or the next vulnerability affects your stack