What’s Vulnerable › Vulnerabilities
CVE-2024-2381: AliExpress Dropshipping with AliNext Lite <= 3.3.5 - Authenticated (Subscriber+) Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-06-17
- Weakness: CWE-434
Description
The AliExpress Dropshipping with AliNext Lite plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the ajax_save_image function in all versions up to, and including, 3.3.5. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- ali2woo AliExpress Dropshipping Plugin for WooCommerce & WordPress: before 3.3.6 — fixed in 3.3.6
How to fix
Upgrade to a fixed version: ali2woo AliExpress Dropshipping Plugin for WooCommerce & WordPress 3.3.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ali2woo-lite/trunk//includes/classes/controller/WooCommerceProductEditController.php#L108
- https://plugins.trac.wordpress.org/changeset/3107543/ali2woo-lite/trunk/includes/classes/controller/WooCommerceProductEditController.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c3248327-6e10-420e-83cf-a23296eb2e6f?source=cve
- https://plugins.trac.wordpress.org/browser/ali2woo-lite/trunk//includes/classes/controller/WooCommerceProductEditController.php#L108
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c3248327-6e10-420e-83cf-a23296eb2e6f?source=cve
Get alerted when CVE-2024-2381 or the next vulnerability affects your stack