What’s Vulnerable › Vulnerabilities
CVE-2024-23820: OpenFGA DoS
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-26 · updated 2026-06-17
- Weakness: CWE-770
Description
OpenFGA, an authorization/permission engine, is vulnerable to a denial of service attack in versions prior to 1.4.3. In some scenarios that depend on the model and tuples used, a call to `ListObjects` may not release memory properly. So when a sufficiently high number of those calls are executed, the OpenFGA server can create an `out of memory` error and terminate. Version 1.4.3 contains a patch for this issue.
Affected products
- openfga: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: openfga 1.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/commit/908ac85c8b7769c8042cca31886df8db01976c39
- https://github.com/openfga/openfga/releases/tag/v1.4.3
- https://github.com/openfga/openfga/security/advisories/GHSA-rxpw-85vw-fx87
- https://github.com/openfga/openfga/commit/908ac85c8b7769c8042cca31886df8db01976c39
- https://github.com/openfga/openfga/releases/tag/v1.4.3
- https://github.com/openfga/openfga/security/advisories/GHSA-rxpw-85vw-fx87
Get alerted when CVE-2024-23820 or the next vulnerability affects your stack