What’s Vulnerable › Vulnerabilities
CVE-2024-23828: Nginx-UI authenticated RCE through injecting into the application config via CRLF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-29 · updated 2026-06-17
- Weakness: CWE-74
Description
Nginx-UI is a web interface to manage Nginx configurations. It is vulnerable to an authenticated arbitrary command execution via CRLF attack when changing the value of test_config_cmd or start_cmd. This vulnerability exists due to an incomplete fix for CVE-2024-22197 and CVE-2024-22198. This vulnerability has been patched in version 2.0.0.beta.12.
Affected products
- 0xJacky nginx-ui: before 2.0.0; 2.0.0-beta1, 2.0.0-beta10, 2.0.0-beta10_patch, 2.0.0-beta11, 2.0.0-beta2, 2.0.0-beta3 (+11) — fixed in 2.0.0
How to fix
Upgrade to a fixed version: 0xJacky nginx-ui 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-qcjq-7f7v-pvc8
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-qcjq-7f7v-pvc8
Get alerted when CVE-2024-23828 or the next vulnerability affects your stack