What’s Vulnerable › Vulnerabilities
CVE-2024-23831: Privilege escalation through CSRF attack on 'setup.pl'
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-02 · updated 2026-06-17
- Weakness: CWE-352
Description
LedgerSMB is a free web-based double-entry accounting system. When a LedgerSMB database administrator has an active session in /setup.pl, an attacker can trick the admin into clicking on a link which automatically submits a request to setup.pl without the admin's consent. This request can be used to create a new user account with full application (/login.pl) privileges, leading to privilege escalation. The vulnerability is patched in versions 1.10.30 and 1.11.9.
Affected products
- ledgersmb/ledgersmb: from 1.3.0 before 1.10.30; from 1.11.0 before 1.11.9 — fixed in 1.10.30, 1.11.9
How to fix
Upgrade to a fixed version: ledgersmb/ledgersmb 1.10.30, 1.11.9. Check the vendor advisory for mitigations.
References
- https://github.com/ledgersmb/LedgerSMB/commit/8c2ae5be68a782d62cb9c0e17c0127bf30ef4165
- https://github.com/ledgersmb/LedgerSMB/security/advisories/GHSA-98ff-f638-qxjm
- https://github.com/ledgersmb/LedgerSMB/commit/8c2ae5be68a782d62cb9c0e17c0127bf30ef4165
- https://github.com/ledgersmb/LedgerSMB/security/advisories/GHSA-98ff-f638-qxjm
Get alerted when CVE-2024-23831 or the next vulnerability affects your stack