What’s Vulnerable › Vulnerabilities
CVE-2024-23835: Suricata's pgsql: memory exhaustion use on record parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-26 · updated 2026-06-17
- Weakness: CWE-400
Description
Suricata is a network Intrusion Detection System, Intrusion Prevention System and Network Security Monitoring engine. Prior to version 7.0.3, excessive memory use during pgsql parsing could lead to OOM-related crashes. This vulnerability is patched in 7.0.3. As workaround, users can disable the pgsql app layer parser.
Affected products
- Fedoraproject Fedora: 38, 39
- OISF suricata: from 7.0.0 before 7.0.3 — fixed in 7.0.3
How to fix
Upgrade to a fixed version: OISF suricata 7.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/OISF/suricata/commit/86de7cffa7e8f06fe9d600127e7dabe89c7e81dd
- https://github.com/OISF/suricata/commit/f52c033e566beafb4480c139eb18662a2870464f
- https://github.com/OISF/suricata/security/advisories/GHSA-8583-353f-mvwc
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GOCOBFUTIFHOP2PZOH4ENRFXRBHIRKK4/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZXJIT7R53ZXROO3I256RFUWTIW4ECK6P/
- https://redmine.openinfosecfoundation.org/issues/6411
- https://github.com/OISF/suricata/commit/86de7cffa7e8f06fe9d600127e7dabe89c7e81dd
- https://github.com/OISF/suricata/commit/f52c033e566beafb4480c139eb18662a2870464f
- https://github.com/OISF/suricata/security/advisories/GHSA-8583-353f-mvwc
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GOCOBFUTIFHOP2PZOH4ENRFXRBHIRKK4/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZXJIT7R53ZXROO3I256RFUWTIW4ECK6P/
- https://redmine.openinfosecfoundation.org/issues/6411
Get alerted when CVE-2024-23835 or the next vulnerability affects your stack