What’s Vulnerable › Vulnerabilities
CVE-2024-2389: Flowmon Unauthenticated Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 93.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-02 · updated 2026-06-17
- Weakness: CWE-78
Description
In Flowmon versions prior to 11.1.14 and 12.3.5, an operating system command injection vulnerability has been identified. An unauthenticated user can gain entry to the system via the Flowmon management interface, allowing for the execution of arbitrary system commands.
Affected products
- Progress Software Flowmon: before 11.1.14; from 12.0.0 before 12.3.5 — fixed in 11.1.14, 12.3.5
How to fix
Upgrade to a fixed version: Progress Software Flowmon 11.1.14, 12.3.5. Check the vendor advisory for mitigations.
References
- https://support.kemptechnologies.com/hc/en-us/articles/24878235038733-CVE-2024-2389-Flowmon-critical-security-vulnerability
- https://www.flowmon.com
- https://support.kemptechnologies.com/hc/en-us/articles/24878235038733-CVE-2024-2389-Flowmon-critical-security-vulnerability
- https://www.flowmon.com
Get alerted when CVE-2024-2389 or the next vulnerability affects your stack