What’s Vulnerable › Vulnerabilities

CVE-2024-23897: Jenkins Command Line Interface (CLI) Path Traversal Vulnerability

Description

Jenkins 2.441 and earlier, LTS 2.426.2 and earlier does not disable a feature of its CLI command parser that replaces an '@' character followed by a file path in an argument with the file's contents, allowing unauthenticated attackers to read arbitrary files on the Jenkins controller file system.

Summary

Jenkins 2.441 and earlier, and LTS 2.426.2 and earlier, fail to disable a CLI parser feature that expands '@' followed by a file path into the file's contents, letting unauthenticated attackers read arbitrary files on the controller (CVSS 9.8). This is listed in CISA's Known Exploited Vulnerabilities catalog with active exploitation, a public exploit exists, and EPSS estimates a 100% chance of exploitation in 30 days. Upgrade to Jenkins 2.442 or LTS 2.426.3; if you cannot patch immediately, apply the vendor's mitigations or discontinue use of the product.

تسمح ثغرة في Jenkins 2.441 والإصدارات الأقدم، وLTS 2.426.2 والإصدارات الأقدم، لمهاجمين غير مصادق عليهم بقراءة ملفات عشوائية على نظام ملفات متحكم Jenkins، لأن ميزة في محلل أوامر CLI تستبدل '@' متبوعًا بمسار ملف بمحتوى الملف ولا تُعطَّل (CVSS 9.8). الثغرة مدرجة في كتالوج CISA للثغرات المعروفة الاستغلال مع استغلال نشط، ويتوفر استغلال عام، وتقدّر EPSS احتمال الاستغلال خلال 30 يومًا بنسبة 100%. يجب الترقية إلى Jenkins 2.442 أو LTS 2.426.3، وفي حال تعذّر الترقية الفوري يُطبَّق تخفيف وفق تعليمات المورّد أو يُوقف استخدام المنتج.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.426.3, 2.442. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-23897 or the next vulnerability affects your stack