What’s Vulnerable › Vulnerabilities
CVE-2024-23907
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-14 · updated 2026-06-17
- Weakness: CWE-427
Description
Uncontrolled search path in some Intel(R) High Level Synthesis Compiler software before version 23.4 may allow an authenticated user to potentially enable escalation of privilege via local access.
Affected products
- Altera High Level Synthesis Compiler: before 23.4 — fixed in 23.4
- Intel(R) oneAPI DPC++/C++ Compiler: before 2024.1 — fixed in 2024.1
- Intel(R) Quartus Prime Pro and Standard edition software: before 23.4 — fixed in 23.4
How to fix
Upgrade to a fixed version: Altera High Level Synthesis Compiler 23.4; Intel(R) oneAPI DPC++/C++ Compiler 2024.1; Intel(R) Quartus Prime Pro and Standard edition software 23.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-23907 or the next vulnerability affects your stack