What’s Vulnerable › Vulnerabilities
CVE-2024-23952: Apache Superset: Allows for uncontrolled resource consumption via a ZIP bomb (version range fix for CVE-2023-46104)
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-14 · updated 2026-06-17
- Weakness: CWE-400
Description
This is a duplicate for CVE-2023-46104. With correct CVE version ranges for affected Apache Superset. Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or datasets. This vulnerability exists in Apache Superset versions up to and including 2.1.2 and versions 3.0.0, 3.0.1.
Affected products
- Apache Superset: before 2.1.3; from 3.0.0 before 3.0.2 — fixed in 2.1.3, 3.0.2
How to fix
Upgrade to a fixed version: Apache Superset 2.1.3, 3.0.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/14/2
- http://www.openwall.com/lists/oss-security/2024/02/14/3
- https://lists.apache.org/thread/zc58zvm4414molqn2m4d4vkrbrsxdksx
- http://www.openwall.com/lists/oss-security/2024/02/14/2
- http://www.openwall.com/lists/oss-security/2024/02/14/3
- https://lists.apache.org/thread/zc58zvm4414molqn2m4d4vkrbrsxdksx
Get alerted when CVE-2024-23952 or the next vulnerability affects your stack