What’s Vulnerable › Vulnerabilities
CVE-2024-2402: Better Comments < 1.5.6 - Admin+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Better Comments WordPress plugin before 1.5.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Better Comments: before 1.5.6 — fixed in 1.5.6
How to fix
Upgrade to a fixed version: Better Comments 1.5.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/98e050cf-5686-4216-bad1-575decf3eaa7/
- https://wpscan.com/vulnerability/98e050cf-5686-4216-bad1-575decf3eaa7/
Get alerted when CVE-2024-2402 or the next vulnerability affects your stack