What’s Vulnerable › Vulnerabilities
CVE-2024-2409: MasterStudy LMS <= 3.3.1 - Unauthenticated Privilege Escalation via stm_lms_register AJAX Action
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-29 · updated 2026-06-17
- Weakness: CWE-266
Description
The MasterStudy LMS plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.3.1. This is due to insufficient validation checks within the _register_user() function called by the 'wp_ajax_nopriv_stm_lms_register' AJAX action. This makes it possible for unauthenticated attackers to register a user with administrator-level privileges when MasterStudy LMS Pro is installed and the LMS Forms Editor add-on is enabled.
Affected products
- MasterStudy LMS WordPress Plugin: before 3.3.2 — fixed in 3.3.2
How to fix
Upgrade to a fixed version: MasterStudy LMS WordPress Plugin 3.3.2. Check the vendor advisory for mitigations.
References
- https://docs.stylemixthemes.com/masterstudy-lms/changelog-free-version#id-3.3.2
- https://plugins.trac.wordpress.org/changeset/3059676/masterstudy-lms-learning-management-system
- https://www.wordfence.com/threat-intel/vulnerabilities/id/94736152-b365-4b3a-a786-ed49f7d0fc7a?source=cve
- https://docs.stylemixthemes.com/masterstudy-lms/changelog-free-version#id-3.3.2
- https://plugins.trac.wordpress.org/changeset/3059676/masterstudy-lms-learning-management-system
- https://www.wordfence.com/threat-intel/vulnerabilities/id/94736152-b365-4b3a-a786-ed49f7d0fc7a?source=cve
Get alerted when CVE-2024-2409 or the next vulnerability affects your stack