What’s Vulnerable › Vulnerabilities
CVE-2024-24156
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-03-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability in Gnuboard g6 before Github commit 58c737a263ac0c523592fd87ff71b9e3c07d7cf5, allows remote attackers execute arbitrary code via the wr_content parameter.
Affected products
- gnuboard5: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: gnuboard5 6.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-24156 or the next vulnerability affects your stack