What’s Vulnerable › Vulnerabilities
CVE-2024-24157
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Gnuboard g6 / https://github.com/gnuboard/g6 commit c2cc1f5069e00491ea48618d957332d90f6d40e4 is vulnerable to Cross Site Scripting (XSS) via board.py.
Affected products
- gnuboard5: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: gnuboard5 6.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-24157 or the next vulnerability affects your stack