What’s Vulnerable › Vulnerabilities
CVE-2024-24267
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-05 · updated 2026-06-17
- Weakness: CWE-401
Description
gpac v2.2.1 (fixed in v2.4.0) was discovered to contain a memory leak via the gfio_blob variable in the gf_fileio_from_blob function.
Affected products
- GPAC: from 2.2.1 before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: GPAC 2.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/NixOS/nixpkgs/pull/305402
- https://github.com/gpac/gpac/commit/d28d9ba45cf4f628a7b2c351849a895e6fcf2234
- https://github.com/gpac/gpac/issues/2571
- https://github.com/yinluming13579/gpac_defects/blob/main/gpac_3.md
- https://github.com/gpac/gpac/commit/d28d9ba45cf4f628a7b2c351849a895e6fcf2234
- https://github.com/gpac/gpac/issues/2571
- https://github.com/yinluming13579/gpac_defects/blob/main/gpac_3.md
Get alerted when CVE-2024-24267 or the next vulnerability affects your stack