What’s Vulnerable › Vulnerabilities
CVE-2024-2428: The Ultimate Video Player For WordPress < 2.2.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ultimate Video Player For WordPress WordPress plugin before 2.2.3 does not have proper capability check when updating its settings via a REST route, allowing Contributor and above users to update them. Furthermore, due to the lack of escaping in one of the settings, this also allows them to perform Stored XSS attacks
Affected products
- The Ultimate Video Player For WordPress: before 2.2.3 — fixed in 2.2.3
How to fix
Upgrade to a fixed version: The Ultimate Video Player For WordPress 2.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4832e223-4571-4b45-97db-2fd403797c49/
- https://wpscan.com/vulnerability/4832e223-4571-4b45-97db-2fd403797c49/
Get alerted when CVE-2024-2428 or the next vulnerability affects your stack