What’s Vulnerable › Vulnerabilities
CVE-2024-2429: Salon booking system <= 9.6.5 - Settings Update via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-352
Description
The Salon booking system WordPress plugin through 9.6.5 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
Affected products
- Salon booking system: before 9.6.6 — fixed in 9.6.6
How to fix
Upgrade to a fixed version: Salon booking system 9.6.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1c6812d8-a218-4c15-9e2d-d43f3f3b0e78/
- https://wpscan.com/vulnerability/1c6812d8-a218-4c15-9e2d-d43f3f3b0e78/
Get alerted when CVE-2024-2429 or the next vulnerability affects your stack