What’s Vulnerable › Vulnerabilities
CVE-2024-2430: Website Content in Page or Post < 2024.04.09 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Website Content in Page or Post WordPress plugin before 2024.04.09 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Website Content in Page or Post: before 2024.04.09 — fixed in 2024.04.09
How to fix
Upgrade to a fixed version: Website Content in Page or Post 2024.04.09. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/990b7d7a-3d7a-46d5-9aeb-740de817e2d9/
- https://wpscan.com/vulnerability/990b7d7a-3d7a-46d5-9aeb-740de817e2d9/
Get alerted when CVE-2024-2430 or the next vulnerability affects your stack