What’s Vulnerable › Vulnerabilities
CVE-2024-24303
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-07 · updated 2026-06-17
- Weakness: CWE-89
Description
SQL Injection vulnerability in HiPresta "Gift Wrapping Pro" (hiadvancedgiftwrapping) module for PrestaShop before version 1.4.1, allows remote attackers to escalate privileges and obtain sensitive information via the HiAdvancedGiftWrappingGiftWrappingModuleFrontController::addGiftWrappingCartValue() method.
Affected products
- Hipresta Gift Wrapping Pro: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: Hipresta Gift Wrapping Pro 1.4.1. Check the vendor advisory for mitigations.
References
- https://security.friendsofpresta.org/modules/2024/02/06/hiadvancedgiftwrapping.html
- https://security.friendsofpresta.org/modules/2024/02/06/hiadvancedgiftwrapping.html
Get alerted when CVE-2024-24303 or the next vulnerability affects your stack