What’s Vulnerable › Vulnerabilities
CVE-2024-2441: VikBooking < 1.6.8 - Insecure Direct Object References
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-285
Description
The VikBooking Hotel Booking Engine & PMS WordPress plugin before 1.6.8 allows direct access to menus, allowing an authenticated user with subscriber privileges or above, to bypass authorization and access settings of the VikBooking Hotel Booking Engine & PMS WordPress plugin before 1.6.8's they shouldn't be allowed to.
Affected products
- e4jvikwp VikBooking Hotel Booking Engine & PMS: before 1.6.8 — fixed in 1.6.8
How to fix
Upgrade to a fixed version: e4jvikwp VikBooking Hotel Booking Engine & PMS 1.6.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9647e273-5724-4a02-868d-9b79f4bb2b79/
- https://wpscan.com/vulnerability/9647e273-5724-4a02-868d-9b79f4bb2b79/
Get alerted when CVE-2024-2441 or the next vulnerability affects your stack