What’s Vulnerable › Vulnerabilities
CVE-2024-2444: Inline Related Posts < 3.5.0 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Inline Related Posts WordPress plugin before 3.5.0 does not sanitise and escape some of its settings, which could allow high privilege users such as Admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Inline Related Posts: before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: Inline Related Posts 3.5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/214e5fd7-8684-418a-b67d-60b1dcf11a48/
- https://wpscan.com/vulnerability/214e5fd7-8684-418a-b67d-60b1dcf11a48/
Get alerted when CVE-2024-2444 or the next vulnerability affects your stack