What’s Vulnerable › Vulnerabilities

CVE-2024-2445: Reflected XSS in Mattermost Jira plugin

Description

Mattermost Jira plugin versions shipped with Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3 fail to escape user-controlled outputs when generating HTML pages, which allows an attacker to perform reflected cross-site scripting attacks against the users of the Mattermost server.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.10, 9.2.6, 9.3.2, 9.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-2445 or the next vulnerability affects your stack